Unscheduled Second Life Community Forum Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted May 27, 2025 - 06:06 PDT

Update

We are continuing to monitor for any further issues.
Posted May 26, 2025 - 09:36 PDT

Monitoring

We’re currently aware of an issue where the Second Life Community Forums may intermittently display error messages or experience unusually long load times. Our team is actively monitoring the situation and working to identify the cause.

We’ll provide updates here as soon as more information becomes available.
Posted May 26, 2025 - 09:36 PDT
This incident affected: Websites (community.secondlife.com).