Unscheduled my.secondlife.com Maintenance
Incident Report for Second Life
Resolved
Maintenance has been completed on my.secondlife.com and in-world profiles.
Posted 3 months ago. May 05, 2017 - 15:03 PDT
Investigating
We are currently performing unscheduled maintenance on my.secondlife.com. While this maintenance is in progress, profiles may be slow to load or unavailable. Please keep an eye on this blog for updates.
Posted 3 months ago. May 05, 2017 - 07:08 PDT
This incident affected: Websites (secondlife.com, my.secondlife.com).