Investigating Process Credit Request Issue
Incident Report for Second Life
Resolved
Our Engineering Team has resolved the issue affecting Process Credit Requests. We thank you for your patience.
Posted 4 months ago. Mar 27, 2018 - 18:34 PDT
Investigating
Our engineering team is currently investigating an issue affecting Process Credit Requests -- specifically, when customers attempt to request a new process credit they may encounter a problem when entering their password.

If you encounter an invalid password response when attempting a process credit request, please clear your browser’s cache and try again. This should fix the problem while our engineering team works on the issue. If this does not resolve the issue, please contact the Support team to request further assistance.
Posted 4 months ago. Mar 27, 2018 - 16:27 PDT