Unscheduled Maintenance to RC Magnum and Cake Channels
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 21, 2017 - 14:43 PDT
Investigating
We are performing unscheduled maintenance to our RC Magnum and Cake server channels. Please refrain from rezzing no copy objects and remember to save all builds. Please check this blog for updates.
Posted about 1 month ago. Jun 21, 2017 - 13:18 PDT