Customers Having Trouble Adding A Payment Method To Their Account
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 06, 2017 - 18:41 PST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Mar 06, 2017 - 16:54 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).