Unscheduled Maintenance to Live Chat service
Incident Report for Second Life
Resolved
The maintenance has been completed.
Posted Jan 21, 2021 - 09:32 PST
Investigating
We are experiencing a few issues with our chat service which may result in slow response times from agents. Thank you for your patience!
Posted Jan 21, 2021 - 07:33 PST
This incident affected: External Support (Chat Support).