Community Site Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 10:54 PST
Investigating
We are aware that the Community page is currently inaccessible. At this time residents may not be able to access the Community Blog or Forum. Please follow this blog for any further updates.
Posted Dec 10, 2021 - 10:02 PST
This incident affected: Websites (community.secondlife.com).