Issues with payments

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Oct 20, 2020 - 23:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2020 - 22:48 PDT

Investigating

We are aware of issues with payments. Our engineers are investigating.
Posted Oct 20, 2020 - 22:27 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).