Issue Viewing L$ Transaction History
Incident Report for Second Life
Resolved
This issue has been resolved. If you are still unable to access your L$ Transaction Log on any of your Non-Premium accounts, please let us know by contacting us through Live Chat or submitting a Support Ticket.
Posted 11 months ago. Jan 02, 2018 - 11:46 PST
Investigating
We are currently investigating an issue that some Non-Premium accounts may be experiencing with viewing their L$ Transaction History. We apologize for any inconvenience that this may cause you, and will provide updates via this blog as they become available. Thank you for your patience.
Posted 11 months ago. Jan 02, 2018 - 07:02 PST
This incident affected: Inworld Services (L$ Transactions).