Partial Outage with Skrill
Incident Report for Second Life
Resolved
This issue has been resolved. If you continue to experience any trouble using a Skrill account to make purchases, please first remove and re-add the payment method at https://accounts.secondlife.com/billing_information/, or otherwise contact support!
Posted Jun 08, 2020 - 15:18 PDT
Identified
We have identified the issue causing some Residents to have trouble using their Skrill payment method. If you are experiencing a problem transacting with your Skrill account, please try removing and re-adding the account at https://accounts.secondlife.com/billing_information/.
Posted Jun 04, 2020 - 16:15 PDT
Investigating
We have been made aware of an issue with the Skrill payment method that may prevent some residents from transacting, and we are currently investigating. Removing and re-adding the Skrill account may help alleviate this.
Posted Jun 04, 2020 - 07:28 PDT
This incident affected: Second Life Services (LindeX Purchases).