Second Life Community Pages
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance on the Second Life Community pages. Thank you for your patience during this time.
Posted 3 months ago. Feb 25, 2019 - 15:42 PST
Investigating
We are currently performing unscheduled maintenance on the Second Life Community pages. While this maintenance is in progress, some users may be unable to access the Community pages (Blogs, Forums, etc.) Please watch this blog for updates.
Posted 3 months ago. Feb 25, 2019 - 11:05 PST
This incident affected: Websites (community.secondlife.com).