Traffic numbers unreliable

Incident Report for Second Life

Identified

We've identified the cause of the issue. We should see traffic numbers recover within 24 hours.
Posted Mar 02, 2025 - 22:05 PST

Investigating

We are aware that traffic numbers in search and parcel info are currently showing incorrect (too low) numbers. Traffic numbers in the Destination Guide are still correct.
We are investigating the cause and apologize for the interruption.
Posted Mar 01, 2025 - 21:24 PST