Concierge and Premium Plus Phone and Live Chat Support Maintenance
Incident Report for Second Life
Resolved
The maintenance has been resolved.
Posted Aug 06, 2024 - 06:09 PDT
Identified
Concierge and Premium Plus Phone and Live Chat Support Maintenance will be undergoing maintenance for the remainder of the day. We sincerely apologize for any inconvenience this may cause. Ticket submissions will still be available. We expect to re-open tomorrow at our normal time.
Posted Aug 05, 2024 - 12:09 PDT
This incident affected: External Support (Chat Support, Phone Support).