Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
This week's Premium Stipends have been dispersed. For any residents that did not receive today's stipend please contact Support.
Posted 11 days ago. Nov 06, 2018 - 09:29 PST
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 11 days ago. Nov 06, 2018 - 06:32 PST