Second Life Marketplace Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Apr 19, 2020 - 15:04 PDT

Investigating

We are aware that Residents are receiving errors while trying to access the Second Life Marketplace. Our operations team is investigating.
Posted Apr 19, 2020 - 14:47 PDT
This incident affected: Websites (marketplace.secondlife.com).