Second Life Login & Live Chat Issues
Incident Report for Second Life
Resolved
This incident has been resolved. Please contact Support if any assistance is needed logging into your account.
Posted Oct 25, 2023 - 09:29 PDT
Investigating
We're investigating a rare issue that may affect some Residents' ability to log in to both the viewer and the dashboard. If you are experiencing issues logging in to your account, please contact Support for further assistance.
Posted Oct 16, 2023 - 08:37 PDT
This incident affected: Websites (secondlife.com), Second Life Services (Logins), and External Support (Chat Support).