Issues with Voice Chat

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 07:37 PDT

Investigating

We are aware of a disruption with our voice service and are investigating at this time. We're doing our best to resolve this issue quickly and will update you here with further information as soon as it's available. Thank you for your patience!
Posted Jul 20, 2025 - 07:18 PDT
This incident affected: Inworld Services (Voice Chat).