Unscheduled Phone Support Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted May 10, 2026 - 15:01 PDT

Investigating

We are currently undergoing unscheduled maintenance for our Phone Support lines. Ticket submission and Live Chat Support will still be available.
Posted May 10, 2026 - 06:38 PDT
This incident affected: External Support (Phone Support).