Premium Stipends Delayed

Incident Report for Second Life

Resolved

Stipends have been paid. Thank you for your patience!
Posted May 19, 2020 - 14:39 PDT

Investigating

We are aware the Stipends have been delayed for some Premium members. We are investigating and expect them to be paid out soon. Please monitor this blog for updates.
Posted May 19, 2020 - 09:19 PDT