Linden Realms Unscheduled Maintenance
Incident Report for Second Life
Resolved
This maintenance is now complete!
Posted about 1 month ago. Jun 15, 2018 - 13:12 PDT
Identified
Linden Realms is currently undergoing unscheduled maintenance. Access to Linden Realms regions, portals and associated Linden Realms activities may be interrupted until the maintenance is complete. Once maintenance has concluded we expect Linden Realms access and activities to be available for regular use. Updates will be posted here as they are available.
Posted about 1 month ago. Jun 15, 2018 - 12:33 PDT