Second Life Profile Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. May 06, 2019 - 08:44 PDT
Investigating
Some residents may be experiencing issues updating their Second Life profile pages at this time. We are working to resolve this issue as quickly as possible, and will provide information here as it becomes available.
Posted 4 months ago. May 02, 2019 - 11:09 PDT
This incident affected: Inworld Services (Profiles).