Second Life crash on Windows with some Intel GPUs
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 10:04 PDT
Monitoring
We have released the viewer with the included Intel fixes! Head over to https://releasenotes.secondlife.com/viewer/7.1.10.10622905308.html and let us know what you think at https://feedback.secondlife.com/ .
Posted Aug 30, 2024 - 11:03 PDT
Identified
We have seen an increase in crashes for some Residents on Windows with older Intel HD-based graphics (GPUs) after the latest release of Second Life Viewer 7.1.9.

We want to provide an alternative viewer that fixes this issue as quickly as possible, so that Residents may start using it now, even before we have completed our regular QA process. There will be a rigorously tested Second Life release candidate (RC) of this same DeltaFPS build made available in the coming days.

The immediate Windows build may be downloaded from GitHub https://github.com/secondlife/viewer/releases/download/Second_Life_Release%23b0fefd6-DeltaFPS1/Second_Life_7_1_10_10622905308_x86_64_Setup.exe
Alternatively, you may wait for the release of DeltaFPS and download it when ready from https://releasenotes.secondlife.com/viewer.html
Posted Aug 29, 2024 - 16:03 PDT