Dashboard Process Credit History Status Column Broken for Chrome Users
Incident Report for Second Life
Resolved
We are resolving this issue at this time, as we finalize a fix for the issue.
Posted Jul 12, 2023 - 10:06 PDT
Investigating
We have identified an issue happening as early as June 2nd regarding with statuses of the Process Credit Request (PCR) History page on the dashboard (secondlife.com) for users of Google Chrome. The column on the PCR History dashboard page that contains the Status of a PCR will appear blank to anyone using the web browser Google Chrome. As a temporary solution, using Firefox, Safari, or a non-chromium based browser to view your PCR History is a reliable workaround. Please watch this blog for updates.
Posted Jun 09, 2023 - 12:43 PDT