Newest Firestorm Viewer Download Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 14, 2016 - 15:15 PST
Monitoring
We’re aware of issues Firestorm is experiencing with downloading their newest viewer release. We’re all thrilled that there’s so much interest in everyone getting their hands on a Bento-enabled viewer. To help Firestorm users obtain the latest update, we are setting up an official mirror for the download. We will update with links as soon as they’re ready.

Please be careful and refrain from downloading viewers from links handed out Inworld - there are multiple instances of such downloads including keyloggers (which will steal your login information as well as monitor all of your communication).

Please watch this blog for the link.
Posted 10 months ago. Dec 14, 2016 - 10:30 PST