Unscheduled Maintenance to SecondLife.com login portal
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 11:54 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2024 - 10:55 PST
Investigating
We are currently investigating an issue on SecondLife.com where the login link is overlapping with the language selector link, and expect a fix soon. In the meantime, you may access your dashboard directly by visiting https://secondlife.com/my/. If you're not logged in you'll be prompted to do so. Please follow this blog for updates.
Posted Jan 04, 2024 - 10:52 PST
This incident affected: Websites (secondlife.com).