Scheduled Inventory Database Upgrades

Scheduled for Jul 27, 05:00 - 09:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 27, 2026 - 05:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 24, 2026 - 13:44 PDT

Scheduled

We will be undergoing inventory maintenance on Monday, July 27th at 5:00 AM Pacific Time. Please be advised that logins, in-world inventory access, marketplace purchases, etc. may be temporarily impacted during the maintenance window.
Posted Jul 24, 2026 - 13:42 PDT
This scheduled maintenance affects: Second Life Services (Logins, Marketplace Purchases) and Inworld Services (Rezzing, Inventory).