Login Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 20, 2019 - 14:58 PDT
Investigating
We are currently investigating an issue which may be affecting logins. Please keep an eye on this blog for updates.
Posted about 1 month ago. Mar 20, 2019 - 13:28 PDT
This incident affected: Second Life Services (Logins).