Unscheduled Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance. Thank you for your patience during this time.
Posted 3 months ago. May 08, 2019 - 16:13 PDT
Investigating
Second Life is currently undergoing unscheduled maintenance. This may result in troubles logging on or using inworld services. Please watch this blog for further information.
Posted 3 months ago. May 08, 2019 - 12:43 PDT
This incident affected: Second Life Services (Logins).