Secondlife.com Outage

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 13:50 PDT

Investigating

Secondlife.com and related websites (including the Destination Guide) are currently experiencing service interruptions due to a technical issue. We're very sorry for the inconvenience and will update this blog with new information as it becomes available.
Posted Apr 10, 2025 - 10:37 PDT
This incident affected: Websites (secondlife.com).