Unscheduled Marketplace Listing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 03, 2023 - 12:50 PDT
Investigating
We are currently investigating a Marketplace issue where some listings are no longer visible to Residents. We thank you for your patience while we look into the matter, and please follow this blog for updates.
Posted Jul 31, 2023 - 14:04 PDT
This incident affected: Websites (marketplace.secondlife.com).