Live Chat Support Outage

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jun 23, 2022 - 13:36 PDT

Investigating

Chat support is currently. Ticket submissions will still be available at this time.
Posted Jun 23, 2022 - 13:28 PDT
This incident affected: External Support (Chat Support).