Certain Regions Currently Inaccessible
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 11:54 PST
Investigating
We are aware that certain regions may currently be inaccessible. We are investigating the issue now, and we apologize for the inconvenience. Please follow this blog for updates.
Posted Dec 14, 2021 - 09:37 PST
This incident affected: Second Life Regions (Second Life Main Channel Regions).