Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
Our billing maintenance is now complete.
Posted 29 days ago. Nov 14, 2017 - 11:55 PST
Update
Our unscheduled billing maintenance is now in progress.
Posted 29 days ago. Nov 14, 2017 - 11:34 PST
Update
Our Billing Maintenance has been pushed back until 11:30 AM PST. All billing services will remain available until that time.
Posted 29 days ago. Nov 14, 2017 - 10:29 PST
Investigating
We are performing unscheduled maintenance today, November 14, at approximately 10:30 AM PST. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates.
Posted 29 days ago. Nov 14, 2017 - 05:42 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).