Homestead and Openspace Regions Down on SLS Main Channel

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:11 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 08:40 PDT

Investigating

We have identified an issue with Homestead and Openspace Regions running on our Second Life Server due to a host provider outage. We are currently working on a resolution. Please be advised that Homestead and Openspace Regions may may not be fully functional at this time. We appreciate your patience and will provide updates as soon as more information becomes available.
Posted Oct 21, 2025 - 08:40 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions) and Inworld Services (Teleports).