Live Chat Support Maintenance
Incident Report for Second Life
Resolved
We were able to resolve the issue impacting Live Chat support it should now be available once more.
Posted Mar 16, 2022 - 07:04 PDT
Investigating
Chat support may be unavailable Wednesday, March 16th. Ticket submissions will still be available at this time.
Posted Mar 16, 2022 - 06:50 PDT
This incident affected: External Support (Chat Support, Phone Support).