PayPal Transaction Errors
Incident Report for Second Life
Resolved
This issue has been resolved. If you see any issues after this time, please contact Support.
Posted Jan 16, 2025 - 11:06 PST
Investigating
We are aware that some PayPal transactions are not completing successfully. We are currently investigating this issue. Please watch this blog for updates.
Posted Jan 16, 2025 - 06:39 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).