Billing Maintenance
Incident Report for Second Life
Resolved
The maintenance is complete.
Posted 3 months ago. Mar 07, 2019 - 10:57 PST
Investigating
We are currently performing maintenance on our billing systems. During this maintenance, some billing services may be unavailable. Please watch this blog for updates.
Posted 3 months ago. Mar 07, 2019 - 10:35 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits) and Inworld Services (L$ Transactions).