my.secondlife.com
Incident Report for Second Life
Resolved
This matter has been resolved. Thank you for your patience!
Posted 6 months ago. Jan 21, 2019 - 10:20 PST
Investigating
Some residents may currently have difficulty accessing my.secondlife.com - this issue is under investigation, and we will provide further updates here when we have more information.
Posted 6 months ago. Jan 19, 2019 - 13:42 PST