Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 07:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2022 - 09:55 PDT
Investigating
We are currently undergoing unscheduled billing maintenance. While this maintenance is in progress, residents may be unable to use the cashier or to make purchases. Additionally, residents may have difficulty accessing certain features at this time, including the Marketplace and Skill Gaming Regions. We apologize for any inconvenience.

Please watch this blog for updates.
Posted Jul 13, 2022 - 06:23 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).