Homestead Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 15, 2022 - 09:58 PDT
Investigating
We are currently performing unscheduled maintenance on homestead regions. Some homesteads may be temporarily inaccessible.

At this time, we ask you to refrain from restarting your homesteads while we work to resolve this issue.

We apologize for the inconvenience. Please monitor this blog for additional updates
Posted Apr 15, 2022 - 08:15 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life Release Candidate Regions).