Connectivity Issues to Second Life

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 18:59 PDT

Investigating

We are aware that some Residents may be experiencing problems trying to log into and/or stay connected to Second Life. Our engineers are actively trying to alleviate the issue.

More information will be posted to the status blog as it is available.
Posted Apr 02, 2025 - 18:24 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com, wiki.secondlife.com, my.secondlife.com, feedback.secondlife.com, support.secondlife.com, search.secondlife.com, places.secondlife.com), Second Life Services (Logins, Marketplace Purchases), Second Life Regions (Second Life Main Channel Regions, Second Life Release Candidate Regions), and Inworld Services (Group Text Chat, L$ Transactions, Rezzing, Voice Chat, Profiles, Teleports, Inventory, Group Voice Chat, Experiences).