Concierge Phone Support Unavailable
Incident Report for Second Life
Resolved
This maintenance has been completed.
Posted 3 months ago. May 12, 2019 - 10:31 PDT
Investigating
Concierge phone and chat support will be unavailable from 9:30 AM PDT until 10:30 AM PDT on Sunday, May 12th. Ticket submissions will still be available at this time.
Posted 3 months ago. May 12, 2019 - 09:11 PDT
This incident affected: External Support (Phone Support).