Process Credit Requests through Skrill

Incident Report for Second Life

Monitoring

Residents may now submit Process Credit Requests (payouts) via Skrill. Thank you for your patience while we identified this issue. A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 13:25 PST

Investigating

We are currently seeing some issues with Process Credit Requests (payouts) submitted via Skrill. Our team is investigating the matter, and we will provide updates on this blog as we have more information.
Posted Feb 25, 2025 - 11:20 PST
This incident affects: Second Life Services (Process Credits).