Maptiles may not be refreshing.
Incident Report for Second Life
Monitoring
Our engineers have identified the issue and the problem is scheduled to be resolved overnight during routine updates.
Posted Oct 10, 2024 - 14:49 PDT
Investigating
We are aware of an issue with the World Map not displaying all maptiles correctly, particularly at the higher zoom levels. Our engineers are investigating the issue. We will update this blog as more information becomes available.
Posted Oct 10, 2024 - 13:55 PDT
This incident affects: Websites (secondlife.com, places.secondlife.com).