Concierge Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
The scheduled maintenance has been completed.
Posted 3 months ago. May 25, 2018 - 13:00 PDT
Investigating
Concierge phone and chat support will be unavailable from 12:00 PM to 1:00 PM PDT, Friday, May 25th, 2018. Ticket submissions will still be available.
Posted 3 months ago. May 25, 2018 - 11:53 PDT
This incident affected: External Support (Chat Support, Phone Support).