Unscheduled Marketplace Maintenance

Incident Report for Second Life

Monitoring

We have identified the issue regarding Marketplace subscription and listing enhancements, and a fix is being implemented at this time. Please be sure to double-check your subscription and listing enhancements if you have disabled them prior, as these may revert during this time. We will continue to monitor for issues.
Posted Aug 26, 2025 - 11:35 PDT

Investigating

We are aware and investigating reports involving Marketplace subscriptions and listing enhancements. Please continue to watch this blog for further updates
Posted Aug 26, 2025 - 09:43 PDT
This incident affects: Websites (marketplace.secondlife.com).