Aditi (Beta Grid) Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 01, 2020 - 23:30 PST

Investigating

We are investigating reports of Residents being unable to log into or upload mesh on our beta grid, Aditi. Please watch this blog for further updates.
Posted Dec 01, 2020 - 11:51 PST