Billing Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jun 22, 2022 - 13:44 PDT

Investigating

We will be performing maintenance on our billing systems on Wednesday, June 22 at 1:10 PM PST. While this maintenance is in progress, Residents may be unable to use the cashier or to make purchases. Please watch this blog for updates.
Posted Jun 22, 2022 - 13:12 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).