Receipt emails delayed
Incident Report for Second Life
Resolved
This incident has been resolved. Receipts will flow smoothly. Happy holiday shopping!
Posted Dec 17, 2022 - 22:20 PST
Identified
We are aware of an issue that's causing email receipts for transactions to be delayed. We've identified the issue as caused by a downstream provider, who is implementing a fix. We will continue to monitor this situation. Your transactions are going through successfully, and the emails should catch up soon!
Posted Dec 16, 2022 - 22:38 PST