Temporary PayPal Payment Processing Error

Incident Report for Second Life

Resolved

This issue has been resolved. We appreciate your patience.
Posted Dec 02, 2021 - 18:35 PST

Investigating

We are currently investigating a temporary issue with processing payments via PayPal. Please keep an eye on this blog for further updates.
Posted Dec 02, 2021 - 16:41 PST